PrimeraBar™ Label Software
For the Cyclone C-1000/C-1000P Bar Code Label
Printer
Version 1.0
User’s Guide
Primera Technology, Inc.

System Requirements
Windows 95/98/Me, NT or 2000
PC Configuration: Pentium processor, 32 MB RAM or greater

Starting up
When you use the software the first time, the Select printer driver window will appear. Double click
the PrimaBar icon on the screen. Select Label Dr. 200 printer driver, then click OK. This procedure is
used to ensure that the Cyclone printer driver is installed. Please note that PrimaBar can be run only
when Primera printer driver is installed.
1. Click the File button in the upper left corner to select new.
2. The pop-up menu of Select Printer will appear, then select from the printing options- the way you
want to communicate with your printer.
3. Having set up your printer, select the page-setup from your File menu to decide the layout of your
label.
4. Back to the Main Features screen.
5. To go directly to a particular subject, you can choose buttons on the Main Features screen, use the
Command menu, or open the Tool Palette.

Exiting
Choose Exit from the File menu.
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Main Features Screen
Main Menu
The main window (workplace) is shown when a new session is started with the PrimaBar Lite
application.

Menu Bar
The Menu bar has six drop-down menus. Select menus with the left mouse button and then select
the command you want.

Status bar
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File
New
Open
Save
Save As
Page Setup
Print
Exit

Open a new label
Open an existing label
Save a label
Save a label under a different name
Set options for printing
Print a Label
Exit to the Desktop

Edit
Cut
Copy
Paste
Clear
Select All
Properties

Move highlighted text/barcode/other images to clipboard
Move highlighted text/barcode/other images to clipboard
Paste text/barcode/other images from clipboard to label
Delete highlighted text/barcode/other images in label
Select all text, barcode or other images in current window
Bring up the property menu for the selected text or barcode.

View
Zoom
Color Adjust
Grid Appear
Tool Bars
Language

Zooms in or zooms out.
Adjusts the color of ruler bar, its figures and background on screen.
Displays a non-printable grid.
Selects to show or hide the bars.
Selects the language shown on screen.

Draw
Text
Barcode
Picture
Diagonal
Line
Box
Ellipse

Inserts text, the Text Properties dialog box opens.
Inserts a barcode, the Barcode Properties dialog box opens.
Inserts a picture, the Load Picture from File dialog box opens.
Uses the Diagonal tool to draw diagonal lines.
Uses the Line tool to draw vertical or horizontal lines.
Uses the Box tool to draw open rectangles.
Uses the Ellipse tool to draw circles or ellipses.

Object
Colors, rotates or moves the selected object
Help
Brings up the help topics and information on PrimaBar
You can also select a command by pressing the key that matches the underlined letter in
the command’s name.
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Tool Bar
The Tool Bar buttons let you quickly carry out commands. These same commands can also be found in
the drop-down menus of the Menu bar.

Icon

Description
Creates a new document
Opens an existing document
Saves the active document
Prints the active document
Opens the Page Setup window
Cuts the selection and put it on clipboard
Copies the selection and put it on clipboard
Inserts the clipboard contents
Zooms in
Zooms out
Grid—displays a non-printable grid
Displays program information, version, number
and copyright.
Display help for clicked on buttons, menus and
windows.

Object Format Bar
The Object Format Bar lets you quickly apply formatting to the selected text or an object. When the
selected object is not text, the Font and Font Size text boxes are empty.

Font text box

Font Size text
box
Drop-down arrows

Icon

Description
Click the drop-down arrow to select the font.
Click the drop-down arrow to select the font size.
Applies Bold format to the selected text.
Applies Italic format to the selected text.
Underlines the selected text.
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Rotates the selected text or object 90 degrees to the left.
Rotates the selected text or object 90 degrees to the right.

Ruler
There are two measurements in this program. The measurement can be altered by click on up-left
corner of the ruler.
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Tool Palette
The Tool Palette gives you quick access to drawing tools such as Line and Ellipse, and lets you insert
and format Text and Bar codes.

Icon

Description
Use the Selection tool to select objects or text.
Click the Text icon to insert text; the Text Properties dialog
box opens.
Click the Barcode icon to insert a bar code; the
BARCODE Properties dialog box opens.
This item is currently unavailable.
Click the Picture icon to insert a picture; the Load Picture
from File dialog box opens.
Use the Diagonal tool to draw diagonal lines.
Use the Line tool to draw a vertical or a horizontal line.
Use the Box tool to draw open rectangles.
Use the Ellipse tool to draw circles and ellipses.

The Tool Bar, Object Format Bar and Tool Palette can be moved around by clicking on
them and dragging to a new location.

Shortcut Keys List
The software is essentially mouse driven, but some functions can be called more quickly by pressing a
key combination. Here is the list:
Keys
Functions
CTRL +N
CTRL +O
CTRL +S
CTRL +P
CTRL + X
SHIFT + Delete
CTRL + C
CTRL + Insert
CTRL + V

New label format
Open label file
Save label file
Print label
Cut
Cut
Copy
Copy
Paste
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SHIFT + Insert
Delete
CTRL + A
ESC
ENTER
CTRL + R
CTRL + L
CTRL + “+”
CTRL + “-“
+
F1
F2
F3
SHIFT + F3
F4
F5
F6

Paste
Clear
Select All
Cancel Edit
Display object properties dialog
Object Rotation +90
Object Rotation -90
Object Move To Front
Object Move To Back
Object Move Forward
Object Move Back
Help
Open label file
Save label file
Save label file as ...
Page Setup
Printer settings
Print

Printing Options
Selecting the file then select new to bring up the Select Printer menu. PrimaBar provides three ways
of printing options:

Windows driver
Ordinary users are suggested to select this option, as it supports all Windows
fonts and can meet varied printing requirements
Printer command
This option allows higher speed printing but it only prints the fonts that your printer
supports. Therefore, it is most useful, when you want to print large quantity of
barcodes and variables.
Form-making
This option is not currently supported.
Printer Setup
Having selected the way of printing, then select a printer and enter the variables of
printer configuration. Details please refer to OS or X series User’s manual.
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Layout a Label
Choose Page setup from the File menu or click the Page setup button on the Toolbar to bring up the
following Page setup window.

Field
Automatic sizing

Description
Check this box when the label and backing paper
are same size.

Page dim. < 0.01 inches >
Enter the backing paper dimensions (width and
height) by dropdown menu or self-define it.
Click the Label tab:

Field
Label dim. < 0.01 inches >
Number of labels

Description
Enter the label dimensions (width and height) and
corner roundness.
Enter the number of labels per row and column.

Click the Margins tab:
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Field
Margins dim. < 0.01 inches >
Gap dim. < 0.01 inches >

Description
Enter the dimensions for the left and top margins.
Enter the dimensions for the gap between rows.
When there are more than one label in a row, that
need to be printed, you have to define the
distance between label and label.

Note: For NT4.0 / Win 2000 user, to create a new size, please consult OS User’s Manual —
Communicate with the printer.

Adding Fields
Add Text:
Selecting the Text tool then click on the work place to bring up the following TEXT Properties
window:

This text box is only shown when
True Type Font is selected in the
Font text box.
Information shown here
is dependent on the item
selected at Data Source
Option tab: Click option to designate the text string.
Field
Coordinates & Size

Font

Description
Displays the coordinates (position) of the selected text. You can enter new
coordinates here, or drag the text to a new location; the new coordinates are
displayed.
Click the drop-down arrow to select the font.
When True Type Font is selected, then Point Size and Style text boxes will be
available. (TrueType fonts are fonts that are installed on your system.)
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True Type Font
Point Size
Style
Expand Height
Expand Width
Rotation
Data Source

Fill Color (check box)
Fill Color (button)
Text Color (button)
Remark

When any of the PPLA/PPLB fonts are selected, the Expand Height and
Expand Width text boxes are available. (PPLA and PPLB fonts are fonts that
are installed in the printer’s memory.)
Click the drop-down arrow to select a TrueType font.
Click the drop-down arrow to select the point size for the selected font.
Click the drop-down arrow to select the style for the selected font.
Click the drop-down arrow to select the expand height for the selected font.
Click the drop-down arrow to select expand width for the selected font.
Click the drop-down arrow to rotate the text.
Click the drop-down arrow to select the data source; there are six options:
Fixed, Date, Counter, Input File, When Printed, and Reference.
See Data Source for detailed information.
When this box is checked the following Fill Color button is active.
Click the “Change Fill Color” button to select the background color..
Click “Change Text Color” button to select the text color.
Provides a brief description for the selected setting in the Text Properties
window.

Add Barcodes:
Selecting the Barcode tool then click on the work place to bring up the following Barcode Properties
window:

Data Source Input Field

Information shown here is
dependent on the item
selected at Data Source

Click on the Option tab to designate the barcode.
Field
Barcode type

Rotation
Narrow bar width
Bar height
Data source

Description
The following bar code types are available:
UPC-A, UPC-E, EAN/JAN 8, EAN/JAN 13, 2&5
digit supplemental, Code 39, Extend 39, Code 93,
Extend 93, Code 128A? B? C, UCC-128, Interleaved,
Codabar, 2 of 5, MSI Plessey, HIBC/HIBC-LIC,
Postnet Zip+4
Click the drop-down arrow to rotate the bar code.
Lets you determine the bar code width of the
narrowest bars.
Lets you determine the bar code height of the
narrowest bars.
Click the drop-down arrow to select the data source;
there are six options: Fixed, Date, Counter, Input File,
When Printed, and Reference.
See Data Source for detailed information.
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Supplement
Ratio
Checksum

Human readable
Change font

For specific barcode that requires supplement codes.
The Ratio item adjusts the width ratio between narrow
and thick bars.
The Check digit zone is used to select the bar code
checking mode. Depending on the type of code you
have selected, different options will be proposed.
Select the position to display the human readable line.
Click this button to change the font of the human
readable line.

Add other images
To create a diagonal line:
1.

Do one of the following:
Choose Diagonal from the Draw menu.
Click the Diagonal button on the Tool palette.

2.

Click and hold the left mouse button while dragging to draw the line.

3.

Double-click on the line to open the Diagonal Properties window to make changes to line
thickness and line color.

To create a horizontal or vertical line:
1.

Do one of the following:
Choose Line from the Draw menu.
Click the Line button on the Tool palette.

2. Click and hold the left mouse button while dragging to draw the line.
3.

Double-click on the line to open the Rectangle window to make changes to line thickness and line
color.

To create a rectangle:
1.

Do one of the following:
Choose Box from the Draw menu.
Click the Box button on the Tool palette.

2.

Click and hold the left mouse button while dragging to draw the rectangle.

3.

Double-click on the rectangle to open the Ellipse Properties window to make changes to line
thickness and line color.

To create a circle or ellipse:
1.

Do one of the following:
Choose Ellipse from the Draw menu.
Click the Ellipse button on the Tool palette .

2.

Click and hold the left mouse button while dragging to draw the ellipse.

3.

Double-click on the ellipse to open the Diagonal Properties window to make changes to line
thickness and line color.

To add a picture:
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Selecting the Picture tool then click again on somewhere of the blank workplace to brings up the
following Load Picture File dialog box:

Field
Look in

File name
Files of type

Open
Cancel
Image
Width, Height

Description
Use this text box to search for graphic files (BMP or
DIB). Click the drop-down arrow to change the
drive/directory.
The selected graphic’s file name is shown here.
The selected graphic’s file type is shown here. Click
the drop-down arrow to change the file types that can
be viewed.
Imports the selected graphic to your workspace.
Click to cancel importing a graphic.
Displays a preview (if checked) and size of the
graphic to be imported.
You can adjust the size of the graphic to be printed
here.

Using Data Source
When you want to add a text or a barcode into the designed label, you can select it from following data
sources:
Fixed
Date

Counter
Input file

The screen and printed output are the same.
Displays the date and time according to your system’s real time clock. If you select
Form making, it is according to your printer’s RTC. Choose a format for the date in
the drop-down menu of Date format.
Enter the initial value and increment value in the specified box. The initial value will
be auto counted during printing. This function of increment only supports numerals.
Select a text file (.txt only) as the data source by “Browse” button. This option is
useful, when you have large quantities of data that need to be input. However each
data of the selected file can only contain a maximum of 20 characters for 2 bytes
languages or 40 characters for 1 byte languages.

When printed

1. Specify the maximum length of data string based on byte.
2. Data is entered directly from a keyboard or scanner before printing. selected file is
Note: The limitation of maximum length is just conducive to formatting.
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Reference

1. Enter a variable in Reference Box by browsing.
2. When data source is reference, the selected variable will automatically appear
during printing.
3. It is most useful, when same data has to be assigned to different format.

? Using Reference as data source:
1. Click Browsing button to bring up the following window.
2. Select one variable field to refer.

3. If you just want to refer a portion of the selected data. Click the
Sub-field Define and specify the Start digit and End digit in the blanks.
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Printing Variable Data
1.Click File to select print. In print window, click Variables button.

2. The variable menu will display all the fields that are using “Counter” or “When printed” as their
data source.
3. Click Move Back to decide the priority of data-input.
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4. Click OK to return to the Print window.
5. Click Print button to bring up the following window.
6. Key in the data in specified box.

7. Click OK.
8. The label will be printed automatically.
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